1. Welcome to Taxidermy.net, Guest!
    We have put together a brief tutorial to help you with the site, click here to access it.

Apoxie Sculpt

Discussion in 'Deer and Gameheads' started by drob, Mar 30, 2020.

  1. drob

    drob Active Member

    I use apoxie sculpt to do the finish work on my deer.Just noticed that the two part mixture isn't hardening!?The product I have is a couple of years old but is still soft and workable.Anyone else experience this?
     
  2. Trophy Specialist

    Trophy Specialist Well-Known Member

    No I've never seen it not harden, but I have seen the one part turn yellow and get chunky.
     
    Clovis Point and drob like this.

  3. George

    George The older I get, the better I was.

    OH, I have. Then I noticed that I'd mixed the lids. When I used the "A", I took both lids off. Then I looked at the jar designation and used the "B". Two "A's" or two "B"s" just won't harden. EVER!
     
  4. WLELTD

    WLELTD Active Member

    646
    86
    i bet u mixed same side
     
    drob likes this.
  5. one time I forgot to add hardener when using bondo on a non taxidermy project ..... ruined the
     
  6. one time I forgot to add hardener when using bondo on a non taxidermy project ..... kept waiting and waiting to sand it..... ruined the front seat of my car .......
     
    drob likes this.
  7. Jon S

    Jon S Well-Known Member

    Once, turned out that I hadn't mixed it enough. Try spending a little more time mixing and see.
     
    drob likes this.
  8. brianmrusher

    brianmrusher Member

    36
    56
    I forgot to add part “B” one time and it didn’t harden
     
    drob likes this.
  9. crablover

    crablover Well-Known Member

    117
    282
    The components in both A and B may have settled. Try heating in a micro wave till soft and re mixing both.
     
    tem and drob like this.
  10. WLELTD

    WLELTD Active Member

    646
    86
    no way did components settle, I'm tellen you. he mixed same side
     
  11. drob

    drob Active Member

    Thanks for all the replies.I tried the same product again and it seems to be ok!Think I under mixed it before as Jon S. said.
     
  12. I've had this problem before more than once and it's always been a lids mix up.
     
  13. Jimmy Rimrock

    Jimmy Rimrock Yeah, they come to snuff the rooster

    I tape the jars together, bottom to bottom. The upside down part usually doesn't fall to the lid. I noticed this in a magazine article years ago, one of the many super cool things that I've learned that weren't mentioned, just pictured.

    I also microwave one part of it, prior to mixing.
     
    drob likes this.
  14. tem

    tem Well-Known Member

    i write A & B on the caps and the jars. dont half to worry about mixing them up.